Blocked Elements - can not view, edit, or delete. Persist even with Shields Off

Description of the issue:
I can not view, edit, or remove Blocked Elements that I create using Brave’s Block Element.

More details:
I went onto and used Brave’s context sensitive menu to block the div video-grid. This worked, the video grid no longer displays.

The problem: Now I can’t remove the block. Here is what I tried:

  • I checked the custom filters list, it is empty.

  • I tried unchecking the 2 filter lists I had (e.g., “EasyList Cookie”) so that there were NO filters displaying on the Filters Setting. Restarted brave, went back to video.piped, however no change - the video grid is still not displaying.

  • I tried turning shields OFF for that page, video grid still wouldn’t display.

  • I tried clearing EVERY setting under advanced for the last 24 hours and restarting my browser, still no video grid.

  • I double checked in an incognito window that yes, there is a video grid that displays there.

Finally in desperation I uninstalled brave, restarted my computer, and reinstalled brave. That finally cleared out the blocked element.

So I’ve now done a test on yahoo and am having the same exact experience. The element stays there even though I can’t find it anywhere.

Exact URL of the website in question:
The 2 I’ve tried are: and

Screenshot of the ad as it appears in Brave:
The problem is that it’s NOT appearing.

Here is the example in an incognito window. Note the Scoreboard on the right. This is the element I blocked with Brave’s Block Element

Here is a screenshot in my normal Brave window - you can see the scoreboard contents have been blocked - even though the Shields are OFF

Here is a screenshot of my Filters page. No filter lists are checked and the Create Custom Filters is empty:

Did the issue present with default Shields settings? (yes/no)

Does the site function as expected when Shields are turned off?

Does the ad appear when using a Private window as well? (yes/no)
Yes (but it’s not an ad and I WANT it to appear)

What OS are you using when you see the ad?
Windows 11

Brave version (check About Brave):
Brave is up to date

Version 1.59.124 Chromium: 118.0.5993.117 (Official Build) (64-bit)

Which elements? Not seeing them from the screenshot.

In this example - it is the contents of the scoreboard box on the right. I blocked them (there is nothing in the box because it’s blocked - if you look at the first screenshot from incognito mode, you can see what is supposed to be in the box) and I can’t find anyway to unblock them.

But as I said, this is just an example - it seems to be happening with anything I block. The element IS BLOCKED but my problem is that I can not UNBLOCK it because the block/filter doesn’t show anywhere.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.