Back button not working properly anymore

Description of the issue: About a week ago the back button has become quite terrible. Before (and now on Chrome for example), it was bringing me back to where I was before the left click. Now - not always.
For example, let’s click on [1] on
This redirects us to the first item in References of the same page. Clicking back, I expect to get back to the top of the page. But nothing happens. Only the page address goes back to what it was.
Even funnier it behaves for example on
If I click on the question and then try to go back, it loads some week-old version of the feed page.

Happens on both my PCs.

UPD: I’ve tried my Wiki experiment several times and half of the times it worked properly. I don’t see any pattern in this.

Brave Version( check About Brave): Version 1.30.87 Chromium: 94.0.4606.71 (Official Build) (64-bit)

Additional Information:

Does it happen with your extensions disabled? What about in a private window? Or in a new profile?

Thank you for reaching out.
I came here to ask the same questions as @JimB1 – can you confirm whether or not you get the same behavior under those conditions?

@Mattches @JimB1
I don’t have extensions.
I have tried using a new profile today and for a long time it was fine, but now the first problem has returned. The second example I was not able to reproduce in the new profile.
In a private window I tried a little bit and it was fine.

On my end, I am seeing the expected behavior:

  1. Visit
  2. Scroll down to References and click on a (shown below)
  3. This brings me to another spot on the page – namely
  4. Then, clicking the back button in the browser moves me to the top of the page.

Can you try clearing cache/browsing data for wikipedia? While on Wiki, simply click the Lock icon in the address bar, then Site settings --> Clear data. Refresh the page and try again.

Clearing cache did not help.

In a different/clean profile. Does Brave Beta make any difference?

@fanboynz As with a new user, at first it was fine, but only for a time being.

Unless its an extension causing?


As I said above I don’t have any.

What version of Windows are you running?

And any chance you’re getting low on disk space? I’m starting to wonder if this is manifesting as a result of some underlying ‘system’ problem.

10 Home 20H2, but on the Windows 7 PC the same thing.

154GB free on C.

OK. That is really weird. Is it the same profile on both PCs, synced over with Brave Sync, or are they totally independent?

Weird it is. They are independent, and we’ve tried other profiles above anyway.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.