ADFS Support with integrated windows authentication

Description of the issue:
ADFS authentication to external resources appears to be broken (at least with MS integrated-authentication support.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Visit any adfs-enabled website (confluence, service-now, outlook.office365.com …)

Actual Result (gifs and screenshots are welcome!):

Bad Request - Header Field Too Long

HTTP Error 400. A request header field is too long.

Expected result:
Successful authentication to adfs site and passthrough to destination website

Reproduces how often:
Always

Operating System and Brave Version(See the About Brave page in the main menu):
Microsoft Windows [Version 10.0.15063]
Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)

Additional Information:
This used to work, some months ago. I’m not sure if there was a workstation, ADFS or Brave change.
Chrome works. Edge Works. Brave doesn’t.
Inside a linux VM on the same host, Brave falls back to basic-auth and succeeds. (Suse 15.1/ [Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)])

I have exactly the same issue on my environment with ADFS authentication:
MacOS - 10.15.1
Brave - Version 0.70.123 Chromium: 78.0.3904.97 (Official Build) (64-bit)

Note that it was also working some weeks/months ago. And this is getting very annoying as I need to switch on Safari…

Well as it is unusable in my day to day I will switch to chrome while you fix your stuff. Let us know when you plan to resolve the issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.