Youtube's "Audio Track" switch does not show up in settings

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:
Youtube has a feature that allows certain creators to add multiple different audio tracks to a video to play in different languages. It’s supposed to show up within the video settings alongside subtitle options, but it does not on Brave (it shows on Safari, though!). This means instead a video picks a language and there is no way to change it to the correct one. Turning off Shields does not help.

How can this issue be reproduced?

  1. Go to a Youtube video with the (new) “Audio Track” feature enabled - the one I was trying to watch is MrBeast’s chocolate factory one
  2. Try clicking the gear on the video player to show settings

Expected result:
There should be a setting called “Audio Track”. Here’s a screenshot of how the settings look on Safari:

Instead, there is not:

Brave Version( check About Brave):
Version 1.42 (

Mobile Device details
iPad Pro running iPadOS 15.5 (19F77)

Additional Information:
It seems to be picking the language at the top of the track list - Russian in this case. Don’t know if that factors in at all.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.