Wrong location in linux (cont 3)

Continuing the discussion from Wrong location in linux (cont 2):

Description of the issue:
Brave shows wrong location in Linux desktop.

How can this issue be reproduced?

  1. Open google.com/maps
  2. Click on the show current location button (blue one over zoom buttons)
  3. It shows a location far from mine

Expected result:
Show current location

Brave Version( check About Brave):

Versión 1.60.125 Chromium: 119.0.6045.199 (Build oficial) (64 bits)

Additional Information:

  • Not on VPN
  • Allowed access to location for google.com
  • Already tried removing cookies and cache data, and it didn’t fix it
  • It works on Google Chrome and Firefox browsers and in Gnome Maps application, so not an ISP problem
  • The same occurs in a private window.

I’ve seen lots of posts about this, in one someone said clearing the cache solved for him, but it didn’t do a thing in my case, all of those seem to be dismissed. And I can comment on them.

This problem has been present since I started using brave, I’ve seen lots of similar posts, always the same suggestions from the staf and it never helps. It seems to be a bug in brave, otherwise please tell me what was I doing wrong, considering that I already tried all variants suggested, and all of that is in this description

Update: it happens the same in the snap version, without any customization, and the location detected is the same as the deb distributed version.

Please check the linked topic to see what I already was asked to verify, but of all tests I was asked to perform there was not nothing fundamentally different between brave and other browsers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.