Why is this Ad?

Well this was a first for me that I saw an Ad on YouTube when using Brave. I just clicked this video notification and there’s an Ad running in front of me. The link is mentioned below with the captured picture and some other infos as:

Copyright claims DESTROYING Twitch!?

Did the issue present with default Shields settings? ----> YES

Does the site function as expected when Shields are turned of? ----> IDK what it means, but YouTube sure shows ads when the Brave Shields are off.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. ----> I’m not sure, I’ve been using Brave for over a month with Deffault shield settings and this the time I saw an Ad, the answer is probably No.

Does the site work as expected when using Chrome? ----> Well, if this question says that, does YouTube show Ads on videos when using Chrome, then I’m to say Yes.

Brave PC is on Version 1.9.80 Chromium: 81.0.4044.138 (Official Build) (64-bit)

I just wanted to share this info and wanted Brave team to be aware of this problem.

I know Brave Shield work really well but this Ad was unexpected. Brave Team is not careless and fix the problems real fast, I know this Ads problem will be solved fast as well.

Thanks in advance.

3 Likes

Same thing here… Started yesterday. You can’t even skip them either… What I did for the first time is goto the extensions option in the menu and found a YouTube adblocker for preroll. It sort of works but you get an error which stays displayed for about 3-4 seconds and then the video starts… I’m guessing this is a brand new YouTube algorithm that was just rolled out. I’m sure the Brave team will be on top of this shortly. In the meantime, try the youtube adblock extension.

3 Likes

@SonnyCrack Well, if u wanna use an adblocker, use Adguard Adblocker, it is far more better than any ad filter or AdBlock, it won’t take the time u mentioned, also it works well with site that says they found an adblocker or duckduckgo, when Brave Shield is on.

2 Likes

Thanks - I tried Adguard and 2 other ones, still get that error that holds for 3-4 seconds before the video starts… This has to be brand new from Google within the last 24 hours. If you find something that works currently, let me know. I can assure you it’s not my PC as I have tried it on my desktop and two laptops, the same thing.

2 Likes

There is a suggested fix on this page Suddenly getting YouTube ads?, it worked for me and others but not everyone, you could try the fix suggested by fanboynz about halfway down the page. Hope that helps

1 Like