Where do my downloads go?

Description of the issue:
Full disclosure: There was an Avast blocker/anti-everything/fearmonger installation on this machine before I got my hands on it, and I’m beginning to think it hasn’t uninstalled fully/completely/correctly

brave doesn’t play nicely with downloads: I tried 3 times to get something from sourceforge just now, and each time, something shut the “save to” window.
But wait! there’s more:
a couple of weeks ago, I tried to torrent a magnet link to similar results. the last time, it appeared to have completed and started to seed, but for the life of me and this laptop, it’s nowhere to be found.

I suspect I may have to dual-boot this machine with *buntu/linux and use brave on that side.
If anyone has insights beyond this, please reach out

How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):
Version 1.3.115 Chromium: 80.0.3987.87 (Official Build) (64-bit)

Additional Information:


:point_up: For torrents, unless you elect to Save file on the torrent screen, the torrent file will be downloaded/saved to RAM – so when the torrent tab is closed, the file is wiped. Ensure you use the Save file option on the webtorrent screen to save the files locally.

Can you tell me what exactly you were trying to download from sourceforge?

Xbian was what I was getting from sourceforge.

And yes, I clicked On save File for the torrent each time, yet windows explorer couldn’t find where I chose to put it, and then wouldn’t reveal where it did put it.

I can’t tell you how many times I :fu:t2::fu:t2:at this Windows computer these past weeks. I miss my old *buntu box.

That’s very strange. I would try downloading another torrent, creating a test folder on your desktop (or somewhere easily accessible) and saving the torrent file(s) to that folder to ensure that the browser is putting them where they’re supposed to go.

Sorry but I want to make sure I’m testing the right thing – would you be willing to send me a direct link to the file download page?

Nope. “The folder is empty”.

Again, it took 3-4 tries to select the folder I made on the desktop to put the file into. The file manager window decided to just simply end the destination selection window/process. So: no file for me, and possible issue for you to dig into/track down.
Like I said at the top of the first post, I suspect the Avast package that the previous user installed isnt completely uninstalled/gone, and is likely messing with windoze.

You’re likely correct. I would try to use a system cleaning application (ccCleaner, for example) to locate and remove any lingering files the Avast! package may have left behind.

It’s frustrating.

I’ll look into the cleaner you mention and report back.


1 Like

If you’re still following this, @Mattches go to https://lubuntu.me/downloads/ and click on the magnet link to DL. I’ve tried ccCleaner and it still doesn’t work…and yes, I do have WebTorrent enabled in settings.

(mayhaps this has been cleared up in the update it seems I need to do to brave…standby on that and I’ll report back…)

When I click on a magnet link on the page you shared above, it opens the in-browser webtorrent client as intended:

Then, clicking Save .torrent file brings up the dialog box as expected:

Note that the images were taken on macOS but I ran this same test on Windows with the same results. Are you still getting the same behavior where the “save file” dialog box is closed after clicking Save .torrent file?


I’ll upgrade Brave later today and return with results…

1 Like

UPDATE - same behaviour. I’m having a devil of a time tracking down the source, but I truly suspect it’s the Avast software’s tentacles playing havoc with me here. If it weren’t crucial to keep a windows machine around, I’d’ve ubuntu’d it already and been done with this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.