Web Inspector loading very slowly

When I try to open the Web Inspector apparently nothing happens, then after waiting 5-6 minutes, it loads pretty slowly.
At first I thought it was the 1.21.73 version, so I updated to the current latest version (1.21.74), but it still does it.

I’ve tried reinstalling Brave 2 times but it still does this problem, I even verified on other macOS machines, but couldn’t reproduce this issue.

I am a web developer, so I frequently use this feature, I don’t know why it suddenly stopped working from one day to another.

Here is a link to a video to show what happens: https://youtu.be/O5DdOSf265I

1 Like

Same problem here, on a Mac also. I noticed from your video you use BitWarden, as do I, but disabling it did not solve for me.

This began happening within the past week for me as well. I thought that the dev tools had stopped working, but then 30-60 seconds later, there they are.

Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (x86_64)
macOS 11.2.1

1 Like

Looks like others as well seeing this issue.

1 Like

Same problem on my side

Mac OS 11.2
Brave 1.21.74

1 Like

Funny issue, after restarting my Mac, web inspector open again instantly !

I’m happy it worked for you!
Unfortunately I’ve already tried few times, but nothing changed :frowning:

I can confirm that this issue is still happening at the latest version. I am using Versão 1.21.76 Chromium: 89.0.4389.86 (Versão oficial) (x86_64), at Mac OS Catalina 10.15.7. The inspector only shows after a long time.


This issue appear on my side randomly. I got the issue again now, even with the last release

  • Version 1.21.76 Chromium: 89.0.4389.86 (Build officiel) (x86_64)

I updated to the latest version [ Version 1.21.77 Chromium: 89.0.4389.90 (Official build) (x86_64) ], still having this issue.
I’m also using macOS Catalina 10.15.7

1 Like

Someone opened an issue on Github.

1 Like

Hopefully they will fix it as soon as possible, It’s getting harder to not use this important feature :cold_sweat:

Happens also to me on Linux Mint 19 Cinnamon too. Kernel 4.15.0-139-generic
Yesterday I updated the Brave Nightly to version 1.24.8 Chromium: 89.0.4389.90 (Official Build) nightly (64-bit) from the Brave repo.
The Dev Tools open after a minute and the content in the dev tools loads very slow and is unuseable. Every Tab functionality I click needs a minute to load.

First I wanted to reply to the github Issue, since its not only an OSX issue, but sadly Github is from Microsoft and spies on its users.

1 Like

Following this issue, it seems they have fixed it and tested it, unfortunately it still doesn’t work (at least for me).

macOS Catalina 10.15.7 (19H524)
Brave Version 1.22.67 Chromium: 89.0.4389.90 (Official build) (x86_64)

I have found a solution! I don’t know if it is just a workaround or a legit fix:

  1. Go to Settings->Security
  2. Under Advanced look for Use Secure DNS
  3. Select Use with Cloudflare (or any other DNS of your choice)
  4. Open Dev Tools

It seems that the built-in adblocker is intercepting the devtool call making it very slow!

Hopefully they will fix it soon, but for now I can finally get back to work normally!

Hopes this helps all of you!

Heh, that does seem to fix it for me as well. In addition to Brave’s tracker/ad blocking (the main reason I use the browser) I also run a Pi-hole on my local network. Not about to turn that off. :confused:

I switched to the “developer edition” of another browser a couple weeks ago since I use dev tools throughout the day. Have been pleasantly surprised actually. Since this is the second time something has broke pretty badly for me in Brave, I’ll stick with the other browser for now and circle back in a couple more weeks to see if Brave has gotten this issue sorted.

1 Like

It finally got fixed! I tested the Nightly version and works as expected, the adblocker no longer intercepts the devtool request!
The new release should be out very soon, I’ll leave a link if you want to check out the thread!
Thanks to all for reporting the issue!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.