Video Playback producing visual artifacts - Affects all websites

Description of the issue:
This problem started happening today. Any video playback produces this awful visual artifacts on the highlights and midtones of the video. This happens with all video playback, from autoplaying site videos to streaming on your favorite platform. I also tried disabling hardware acceleration and relaunching; same problem. In the screenshots below, you’ll see the artifacts right away. I tried launching in new windows and also launching a private session and it still produces the same weird bug. My hardware is fine, as no other application on the computer produces these artifacts. I use my workstation for video production so I’m used to dealing with driver issues and recognizing compression when I see it. I’m using the latest version of Brave on a standard browser, no nightly or anything like that.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Launch a new window
  2. Find any video content
  3. Profit

Actual Result (gifs and screenshots are welcome!):

Expected result:
I hope to get it fixed and back to normal. I love using Brave to surf the internet, consume video content, and work from home on it. I hope to receive a software update soon.

Reproduces how often:
Everytime.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Professional (Latest Build), AMD Ryzen 9 3900X, 32GB -DDR4-3600MHz - CL16, AMD Radeon VII, AsRock X570 Tachi, 2TB Sabrent Rocket PCIe Gen 4 NVME SSD

Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (64-bit)

Additional Information:

This browser definitely gets massive cool points from me. this seems like a better version of Google Chrome. Having this privacy focus is awesome and I’m 100% on board. Also, are you still hiring?

Also shows artifacts on still images as well. I do not have HDR turned on

No bandwidth issues? Could also try disabling Hardware accelleration in Brave settings, see if the artifacts still occur. Does it occur in youtube?

error went away idk how. I tried disabling hardware acceleration as well. I should’ve taken a photo with my smartphone instead of screen grabs