Updates on Linux -error messages appearing

Getting error messages when checking for updates
Using the Linux Mint update manager

  1. open update manager
  2. check for updates
  3. Get error messages:
    “The repository ‘https://s3-us-west-2.amazonaws.com/brave-apt xenial Release’ does not have a Release file.Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.Failed to fetch https://s3-us-west-2.amazonaws.com/brave-apt/dists/xenial/main/binary-amd64/Packages 404 Not FoundSome index files failed to download. They have been ignored, or old ones used instead.”

Brave Version( check About Brave):
Brave is version 1.2.41 but the update manager had been showing a 1.2.43 but there is no description of changes in either the update manager or on the community forum. Can both these issues be fixed?
Brave-keyring (which I assume is related to the browser) is showing version 1.7 but 1.9 available. Again, no description even of what this is in the software update manager. No description of what the changes are. Can this also be fixed?

Hello, @convermint. If you’re running Brave Release in Mint 17+ (mine’s 19.3), the repository address doesn’t match what I have or what the instructions have. Maybe the address listed in the instructions and my list forwards to AWS, but I don’t know for sure, and can’t hurt to check. If you’re running a version beyond 19.3, then this might not apply. Here’s what mine looks like and what versions of system things I’m running (click images to enlarge):




To get to your Software Sources from the Update Manager, click Edit and select Software Sources.
image
Click Additional Repositories. If the Brave entry isn’t
deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
then click the Edit button below the list and make it that. When you click OK, you may be prompted to update your cache; go ahead and do that.

Next, click Authentication Keys and check the Brave entry. If it doesn’t show the D8BA D4DE ... E821 string for Brave, you should probably download the key. To do that, click Download and enter the URL for the key from the [Linux installation instructions][1], which is https://brave-browser-apt-release.s3.brave.com/brave-core.asc, and click Download. If successful, you’ll get a message to that effect and be prompted to update your cache; do that.

Once the updating of the cache is done, close Software Sources, return to Update Manager, and click Refresh if necessary, and you should be good to go. As it happens, my re-downloading the key to test my instructions led to some updates showing up that didn’t until then:

I clicked Install Updates, everything downloaded okay, and the installation went okay, too. Hopefully, yours will, too. :slight_smile:

Thanks for the reply.
I am using Mint 18.3 and the entry on my system is similar but with xenial instead of stable.
deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ xenial main

I tried using the Brave install instructions to install the key, and there are two entries now - different number to the one yours shows but maybe that is due to the different version of Mint? I think there were already two entries. One is labelled ‘Brave Software support@brave.com’, the other is labelled ‘Brave Software (We’re reinventing the browser as a user-first platform for speed and privacy) support@brave.com’.
I installed the brave-keyring 1.9 (although would have preferred to have known what I am installing), and the error when I get the list of updates has now disappeared . There is still no explanation of the changes for brave 1.2.43 so would prefer not to install that. I like to know what I am installing first.

Actual proposed resolution steps begin in second paragraph. WRT the extra entry(ies), performing the steps outlined on the installation page would have added stuff since those steps assume you don’t already have Brave, so that’s why you have extra stuff. The key ring is just that - Brave’s gpg/pgp keyring that is used for authenticating the browser and its components, so I wouldn’t sweat installing it. (@Mattches, if you could review this post/thread and correct me as necessary, I’d be much obliged).

@convermint, your point about different Mint versions stuck, so I created a VM of Mint 18.3 to test, followed the install instructions for Brave, and reviewed the resulting entries in Software Sources. Even though there are differences, it looks like my basic ideas about the Brave Repository and Key were sound. So, to get things tidy and functioning try these steps:

  • edit the Brave repository entry in Additional repositories to change it from xenial to stable
    • (should read deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
  • keep the Brave key entry with the Brave Software label without the extra reinventing the browser stuff (I don’t know that keys have the same value for every install of Mint 18.3; mine shows C2D4E821); and
  • remove the other key entry.

Here are movies of the install process, followed by stills of the resulting rep and key screens in Software Sources and Brave showing its version (click to enlarge):



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.