Unable to see Brave in the list of default browsers

I can’t see Brave in the list of available browsers in the Default Apps page of windows settings. How do I add Brave to the recognised list? All I see is Google Chrome, IE, Edge and ‘Look for app in the MS store’.


Can you try via Brave’s Settings > Get started? There you’ll find an option to set Brave as default.

No, it’s a windows setting I need. I can ask for Brave to made the default browser but when I do it’s not available in the list that windows can see. I think it’s a registry setting

I am having the exact same issue after dumping Firefox for Brave a few days ago, and it is very annoying. I can’t open any hyperlinks, either. I’ll give this a few days for someone to solve this, and then I’m uninstalling and switching to Chrome. Sorry, Brave, I really wanted you to work for me.

Well, I decided to just try running the installer again. What do you know, it worked! Brave now shows up in the Control panel in the list of Browser apps that you can set as a default. Glad I didn’t have to give up on it.

I also rebooted the computer prior to that, and it took a long time to boot - maybe it was finishing up some automatic update which might have interfered with the first installation.

1 Like

You beauty…!! Nice one, sorted.