Unable to open the Brave browser on Mac BigSur 11.4

Unable to open the Brave browser on Mac book, running BigSur 14.11.

Error message when I try to open the brave browser installed on my machine,

Process: Brave Browser [16670]
Path: /Volumes/*/Brave Browser.app/Contents/MacOS/Brave Browser
Identifier: com.brave.Browser
Version: 91.1.25.73 (125.73)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Brave Browser [16670]
User ID: 503

Date/Time: 2021-06-16 18:07:57.302 -0700
OS Version: macOS 11.4 (20F71)
Report Version: 12
Bridge OS Version: 5.4 (18P4663)
Anonymous UUID: CD911F1B-851F-5D6B-F26A-4341C9A73F69

Sleep/Wake UUID: 22EBBCAC-315A-434E-A753-9539F8541569

Time Awake Since Boot: 560000 seconds
Time Since Wake: 78000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Trace/BPT trap: 5
Termination Reason: Namespace SIGNAL, Code 0x5
Terminating Process: exc handler [16670]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.brave.Browser.framework 0x000000010feab723 ChromeMain + 74486467
1 com.brave.Browser.framework 0x000000010b90773c ChromeMain + 1463004
2 com.brave.Browser.framework 0x000000010f0bfc7b ChromeMain + 59889691
3 com.brave.Browser.framework 0x000000010b7a4ede ChromeMain + 10878
4 com.brave.Browser.framework 0x000000010eff8056 ChromeMain + 59071478
5 com.brave.Browser.framework 0x000000010eff7f3f ChromeMain + 59071199
6 com.brave.Browser.framework 0x000000010eff6bf9 ChromeMain + 59066265
7 com.brave.Browser.framework 0x000000010eff72ad ChromeMain + 59067981
8 com.brave.Browser.framework 0x000000010b7a2575 ChromeMain + 277
9 com.brave.Browser 0x000000010b73a1bf main + 287
10 libdyld.dylib 0x00007fff205a8f5d start + 1

Thread 1:
0 libsystem_pthread.dylib 0x00007fff20589420 start_wqthread + 0

Thread 2:
0 libsystem_pthread.dylib 0x00007fff20589420 start_wqthread + 0

Thread 3:
0 libsystem_pthread.dylib 0x00007fff20589420 start_wqthread + 0

Model: MacBookPro16,1, BootROM 1554.120.19.0.0 (iBridge: 18.16.14663.0.0,0), 8 processors, 8-Core Intel Core i9, 2.4 GHz, 32 GB, SMC
Graphics: kHW_IntelUHDGraphics630Item, Intel UHD Graphics 630, spdisplays_builtin
Graphics: kHW_AMDRadeonPro5300MItem, AMD Radeon Pro 5300M, spdisplays_pcie_device, 4 GB
Memory Module: BANK 0/ChannelA-DIMM0, 16 GB, DDR4, 2667 MHz, SK Hynix, -
Memory Module: BANK 2/ChannelB-DIMM0, 16 GB, DDR4, 2667 MHz, SK Hynix, -
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x7BF), wl0: Feb 16 2021 03:05:58 version 9.30.444.10.32.5.67 FWID 01-3d719d60
Bluetooth: Version 8.0.5d7, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.1 Bus
USB Device: Yubikey 4 OTP+U2F+CCID
USB Device: Apple T2 Bus
USB Device: Composite Device
USB Device: Touch Bar Backlight
USB Device: Touch Bar Display
USB Device: Apple Internal Keyboard / Trackpad
USB Device: Headset
USB Device: Ambient Light Sensor
USB Device: FaceTime HD Camera (Built-in)
USB Device: Apple T2 Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 63.5
Thunderbolt Bus: MacBook Pro, Apple Inc., 63.5

How can this issue be reproduced?
Download the latest eversion of brave browser and install, then open the app from the application list.

Expected result:
Should open the browser.

Brave Version( check About Brave):
Version: 91.1.25.73 (125.73)

@rakeshraih,
Can you try trashing/deleting any Brave data you have installed on your computer up until this point, and try installing using the following link (select the .dmg or .pkg file) and see if it opens after this?