Unable to open images on Twitter

Description of the issue: When tapping an image on twitter.com, the image fails to display.

How can this issue be reproduced?

  1. Open twitter.com and ensure you are signed in.
  2. Navigate to a Tweet with an image attached to it.
  3. Click on the image.

Expected result: The image in the Tweet would properly load and be displayed to the user.

Brave Version( check About Brave): Version 1.51.2 (

Mobile Device details iPhone 13, iOS 16.5.1

Additional Information: This issue only occurs with shields enabled, likely an issue with a filter. This did not occur before today (unsure as to the last time I updated the app). I have attached a screen recording of the behavior.

Thanks in advance.


I have the same problem on my iPad Pro 12 2nd Gen iPad OS 16.5.1 Brave v1.51.2 - the images do open with Brave Shields DOWN.

Additionally, some videos do not play.

1 Like

@fanboynz I just was able to verify. Videos played perfectly fine for me but if I clicked on images, they would open to black and then do nothing. If I completely disabled Shields, the images would load.

Even turning off the toggles for Trackers & Ads Blocking, Block Scripts, and Block Fingerprinting still would leave it broken. It’s only when completely disabling the toggle for Brave Shields that it would work. I even completely disabled everything in Content Filtering and it made no impact.

I also went and completely disabled every single option under Brave Shields & Privacy but it still wouldn’t load images unless I completely disabled Shields.

Mine also was on iOS 16.5.1.
Brave 1.51.2

1 Like

I know twitter rolled out some updates today, preventing logged out accounts from showing tweets. Does it still occur? Try logging out/re-login into twitter? @crabs @okulo

1 Like

I tried logging out and logging in to see if that would fix anything. After I logged out, I received this error and am unable to load twitter.com at all. The site loads in Private mode.

Try clearing the cookies and cache?

I had the same error, cleared cache and cookies and managed to log in but the image error persists.

Also, the video issue I have is only with some videos and they don’t play (just the spinning thing) on my Mac version of Brave either.

By the way, when I get my Twitter log-in e-mail notification, it says that the log-in was via Safari Desktop on Mac - I never use Safari, my Mac has been asleep for two days and I’m using my iPad.

When you cleared the cookies and cache, did it require you to re-login again?

Had one report that this fixed it.

Yes, as I said.

But no, images are not appearing when tapped.

Does disabling fingerprinting in shields affect it?

Originally I went to Twitter and logged in. As stated, I tried disabling and enabling each of the Shields settings independently and not a single thing made an impact except for completing disabling Shields.

If it would help, I can make a video and share tomorrow of it happening and me changing each of the settings.

So go to Twitter after logging in, where can see everything like first screenshot. Click on an image, such as I clicked on the image of the Swarovski and Marvel new tab takeover shared by Brave Software. Clicking on that image, went black.


Even happens with settings as below:

Earlier I even disabled everything in global settings, but no improvement.

But if disabled Shields:

Clearing cookies and cache also had no impact.

Clearing the cookies and cache did allow me to access the site again. My issue with loading the images still stands. I am experiencing the exact things as described in @Saoiray’s post above (Unable to open images on Twitter - #12 by Saoiray)

Is it specific shields setting?

No, it appears to be the shields in general. Disabling all switches under Advanced Controls in shields settings does not resolve the issue. The issue also exists when either standard or aggressive blocking is enabled. Only disabling shields entirely for twitter.com resolves the issue.

Edit: I also disabled all additional lists under Content Filtering. This did not help.

Do you have VPN, can you test from a different location?

Might delete Brave soon over this errror, sorry

I’m still having the problem and I don’t use a VPN.

FYI, Twitter seems to be having problems at the moment - there is a down detector spike for all the parts of the world which are awake right now - just a small blip in the US where most people will still be in bed.

I’m having the same problem of an expanded image appearing as a black screen on Android, unless Brave Shields are entirely disabled.