Stable release v1.52.117 does not remember Dark theme setting

Brave will always open in Light them for me on Linux Mint, it will have the setting saved as dark theme though when I go to appearances, have to toggle it to Light then back to Dark for it to actually change to Dark theme. Thanks.

Hello @Jebril

it been reported and here a post about it include the whole story

hope they fix it soon and have a nice day :slight_smile:

It’s not the same problem. I also experience the same thing as OP. The last update didn’t solve it, either, it’s still a bug in version 1.52.122.
Not only it ignores the dark mode setting (and no, it does not open the “what’s new in brave” as your linked post suggests), but it also ignores the “Show tab search button” setting. It shows the button on every browser start even if the setting is disabled. It only goes away when I enable it and then disable it again.
I purged my Brave install (config files, cache, everything), but it does the same thing on a new install as well.
I didn’t mind that much when the browser started getting bloated with features that I (and I would guess about 90% of its users) didn’t need (and for which there are many well-established solutions already available on the market that work better), but now it seems like Brave developers are spread too thin between all the projects that Brave have started, and it’s getting noticeable regarding the quality of the browser. Brave devs have dropped the ball again. Between this and the random Brave app crashes on my phone that have been annoying me for months now, I give Brave one last chance before I’m moving to another browser yet again.

EDIT: Seems like it’s an upstream issue with Chromium, so this one’s not on the Brave devs: I hope it gets fixed soon.

I have been waiting weeks for a fix.

Desktop Environments that uses QT instead of GTK seem to have the theme working, such as LXQT or KDE Plasma.

having the same issue.
the way to solve it until you restart brave is.
set brave colors to white and then to dark again. in the appearance tab