Sponsored tweets displaying when logged in on Twitter and visiting a profile

Description of the issue: Sponsored tweets displaying at the top and then every 4 posts when logged in on Twitter and visiting a profile.

Exact URL of the website in question: (example) https://twitter.com/privacytests

Screenshot of the ad as it appears in Brave
When logged in :

In incognito window :

Did the issue present with default Shields settings? (yes/no) Yes, I even tried to disable my regional filter list (Adguard français) but no change.

Brave version (check About Brave): 1.43.93

1 Like

@BrLil6015 check your settings. I believe you have to set it to Aggressively block ads & trackers for it to do its thing.

@Saoiray sorry, should have mentioned it happens on both Agressive and Standard mode for me.

@BrLil6015 What filters do you have? If not enabled, I’d recommend to activate the two below:

  • Fanboy Annoyances List

  • uBlock Annoyances List (used with Fanboy Annoyances List)

@BrLil6015 try adding this into brave://adblock

twitter.com##.css-1dbjc4n[data-testid="placementTracking"] > .css-1dbjc4n > article[class="css-1dbjc4n r-1loqt21 r-18u37iz r-1ny4l3l r-1udh08x r-1qhn6m8 r-i023vh r-o7ynqc r-6416eg"][data-testid="tweet"]

1 Like

@Saoiray I have default filter lists. I used to have both these annoyances lists but the sponsored tweets were still showing.

@fanboynz Thank you ! I added the filter and, indeed, the sponsored tweets disappeared. Although I still see the sponsored header “Tweet sponsorisé” as you can see here :

Yeah, no easy fix for the title, but that should help. If you can test, ensure it doesn’t cause issues. I can roll it out globally.

It’s already helping a lot indeed. Will test it more in depth tomorrow just to be sure but it seems good enough yea.

@fanboynz not really an easy one to test tbh but I didn’t notice any obvious issue since applying the filter. So looks good to me if you want to apply it globally! Thanks again.

1 Like