Some "Submit" Buttons Not Working On Websites

Description of the issue:

Here is the issue; I have gone to make a couple of purchases in web browser (and the same sites in android to verify) and I will get to the end, and some of the final “submit” buttons will not work. Things like submitting a payment, trying to send an email to a company via their web browser software (not through a standard email).

Some of the buttons are greyed out, some of them have a lock symbol next to them, etc (depending on how the web developers implemented the software. It’s not an issue of not filling everything out either. I went to the same sites in Chrome and was able to make the purchase I was trying to make, as well as send the email to the company through their web email.

It seems to be a Brave issue.

How can this issue be reproduced?

1.When trying to submit information, some buttons do not work

Expected result:
Button is unresponsive, a different color, has a “lock” symbol next to it, is greyed out, and will not take me to the next step of whatever process I am trying to complete (email, payment, etc)

Brave Version( check About Brave):

V1.29.81 (Sep 14, 2021)

Additional Information:

Both Chrome and Firefox worked for these other sites when buttons were clicked. None were greyed out, no “lock” symbols, website proceeded as it should

You’ll have to share which websites are problematic for you so @fanboynz can take a look when possible.

As @Rethanis says, can you please provide some example sites where you see this behavior so that I can test and try to reproduce them on my end?

1 Like


Here was one of them, it was just a contact for a site:

The other one was a payment site. It’s when I went through and selected PayPal then it took me back to the vendors page to do a final “submit” of the order, it would not let me submit. That site was:

But you’d likely have to try and make a mock purchase with PayPal. It never submitted so you could likely go through the process of ordering something and it wouldn’t post to the account if it’s a worry.

As I come across more websites that won’t allow me to move forward, but those were the two that I was working with that wouldn’t allow me to continue. Both on desktop and android mobile

Edit; I went back to the contact site today and tried to submit again…it worked this time. I don’t want to go test out a purchase though if I don’t need anything from the second site (I was able to make the purchase via a different browser).

Let me know what you find if you run some tests, maybe it was just something that wasn’t working yesterday? Would be odd but it’s possible.

@shammarstrom Would need more details/directions on how its broken. As a test I went through a basic submission:


Yes, as I mentioned up above, that “Submit” button originally stayed greyed out and did not turn blue and let me submit.

Then the following day, it worked.

The other site (bike parts website) would not let my submit at the very end when I went to submit my payment with their button. I could press the button and nothing would happen. This was the day of the issue. I didn’t want to try it the next day because I had nothing that I needed to order, so it was hit or miss.

I’ll have to follow up if I see the issue come up with other things, but it seemed to be related to any forms/payments that you need to press a button to submit the information. The buttons were not causing it to move forward to the next page or complete a process. Whereas I had completed them fine in Chrome/Firefox

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.