Set a Wayland related flag, now brave won't start

Description of the issue:
I set a Wayland related flag in Brave and now it won’t start.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
If I could remember the flag, I would tell you. However, it is one about the Wayland server type and I set it Wayland (maybe should have been auto.)

Actual Result (gifs and screenshots are welcome!):
Brave won’t start. Gives the following error:
[31386:31386:0206/] Failed to connect to Wayland display: No such file or directory (2)
[31386:31386:0206/] Failed to initialize Wayland platform
[31386:31386:0206/] The platform failed to initialize. Exiting.

Expected result:
Just want to be able to start Brave

Reproduces how often:
Every time I try to start Brave.

Operating System and Brave Version(See the About Brave page in the main menu):
Ubuntu 22.04 LTS
Brave 1.47.186

Additional Information:
Would like to just remove the flag I set so Brave will start.

Hello @gwduvalljr

you can start brave using --no-experiments flag

and this how to start brave using command line with flags

then go to flag and reset them

Hello @gwduvalljr

Thanks for bringing this to our attention and I’m sorry to hear you are going through this. Could you kindly try to reinstall Brave Browser to see if the issue persist? When you uninstall it, delete your browsing data as well then reinstall from the site as usual.

Let us know if that helps!

Hi All,

Thanks for the help.

Turns out the IT guy that loaded Brave on this system used snap. I removed that version and installed the correct version and that fixed my issue. Unfortunately, I had to leave right after I did that and did not have a chance to update this question until now.

I am certain that I will use the flags and other information later, so again, thanks so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.