Save as PDF issue - native finder dialogue getting stuck behind browser dialogue

Description of the issue:
When I try to save a webpage as a PDF (when the browser is fullscreen), the native finder window (MacOS) gets stuck behind the browser save as PDF dialogue.

How can this issue be reproduced?

Video walkthrough:

  1. Make Brave Fullscreen.
  2. Right click any page on the web.
  3. Click ‘Print’.
  4. Click 'Save.
  5. You should see the issue here (no Finder window present to finish the process).

Expected result:
Ability to save a webpage as a PDF in Finder.

Exit fullscreen mode. The native finder save dialogue appears (see video).

Brave Version:
Version 1.58.127 Chromium: 117.0.5938.88 (Official Build) (arm64)

Additional Information:
Tested on: Mac Mini, 2023. Apple M2.
macOS: Venture 13.5.2
Monitor/res: 2560x1080

1 Like

I am facing the same issue

Thank you both for reporting and sorry for the late response here. Also appreciate the detailed recording of the behavior.

@jonzo84 can you please tell me if the issue persists after updating to the latest build (v1.58.137 at the time of writing this)?

What’s interesting is that I fully expected to see this same issue occur on my end but for me the system dialog box appears right over the fullscreen browser window:

I also tried it on my external monitors as well as my Macbook screen. That said, I’m also currently running macOS Sonoma 14 at this time so maybe that has something to do with it. Has the behavior always been this way or is this something that occurred after a recent update?

I have the same issue. I am using the latest version of Brave (1.58.137) but I’m using macOS Monterey 12.6. I don’t know if it’s worth updating my MacOS just to see if the issue has been resolved. I even tried reinstalling Brave but still the problem persists.

I’m guessing this is a Brave problem since I do not have issues with other browsers like Firefox or Safari.

Also having the same issue on MacOS 13.6.
@Mattches video explains it well, the save as dialog box is being hidden.
The solution is to reduce the window size prior to using the save as function, then expected save as dialog box is presented and the file can be saved successfully.

We cannot seem to reproduce this — I’ve gone ahead and opened an issue for the developers to review:

Can you all confirm that the issue is present after updating to the latest version of the browser (1.59.117 at the time of writing this)?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.