Problem when trying to join Rewards

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue: I have a Huawei P40 Pro without Google services, I downloaded Brave Browser and it’s working normally, but I can’t join Rewards because when I press the button it says: Please try again later.

How can this issue be reproduced?

  1. Button

Expected result: Create a wallet to receive ads on my phone

Brave Version( check About Brave): 1.15.76

Mobile Device details Huawei P40 Pro

Additional Information: That’s all, thanks.

Hello @Hecbert4258

brave reward does not work with all custom rom so that expected behaviour but try to update brave first and see if it worked or not
current version is v1.20.103

hope that help and have a nice day :slight_smile:

1 Like

Oh god, I just downloaded that version and it worked!! Thank you so much!!!

congratulations and you very welcome :slight_smile:

1 Like