PDF link result in "Invalid or corrupted PDF file."

Description of the issue:

In Fidelity Investments site when generating an analysis Report, the PDF consistently fails with:

“Invalid or corrupted PDF file.”
PDF.js v2.0.673 (build: 31012570)
Message: Invalid PDF structure

This works correctly in the Chrome Browser

Macbook Pro running MacOS 10.14.5

Brave Version 0.66.101 Chromium: 75.0.3770.142 (Official Build) (64-bit)

Steps to Reproduce (add as many as necessary): 1. 2. 3.

In this link: https://portfolioanalysis.fidelity.com/ftgw/analysis/customer/landing.gps#/reload

There is a Reports link to click that will generate a current report, called “Reports” which is supposed to generate a PDF file. It fails.

Actual Result (gifs and screenshots are welcome!):

Expected result:

PDF file should generate and be viewable

Reproduces how often:

Every time

Operating System and Brave Version(See the About Brave page in the main menu):

“Invalid or corrupted PDF file.”
PDF.js v2.0.673 (build: 31012570)
Message: Invalid PDF structure

Additional Information:

Works fine in Chrome Browser
Reviewed Similar Topics and steps detailed offer no resolution

Hi, @Pil0t_Pete. If you search the community for PDF.js you’ll see more reports very like this, though as you point out none seem to offer an outright fix, and the answers from Brave people suggest it’s a coding issue. Is this correct @Mattches?

So, until the coding is corrected, you could try turning off use of the internal PDF viewer and download the PDFs, then view them with Adobe Reader or something. If that’s what you’re doing and getting the error, then I’m out of ideas. To change Brave’s settings,

Related threads (some of them):

Excellent!!! Thank you hnktong, that works! Actually, it works exactly as the test I ran in the Chrome Browser. Report generated, prompted me to save, when I did I was able to open up the file, no problems!

So, I was looking through the visible settings in the Brave Browser but didn’t see anything like as the link you gave me. Then I remembered the other browsers also usually have somewhat hidden settings as well.

This is GREAT! Works for me! Thanks again!


1 Like

Wow, you’re most welcome, and I’m very glad it worked for you!

1 Like