Not able to claim brave rewards

I am not able to claim brave rewards. When i am clicking on claim button nothing is happening.

There may not be grants available anymore – did you click the claim button soon after you got the notification about a new grant?

1 Like

I tried to claimed after some time

Hi, you probably want to make sure you are disconnected from any VPNs. Also, can you try to claim them from brave://rewards to see if that works?

I have been trying to “CLAIM” the rewards for the past three days. It seems I have spent more than an hour moving that triangle around. Does the fact that I am complaining prove I am human? If it is a scam just say so and I will pick up my toys and go somewhere else.

I have the same issue. The reward was not there before I went to work and when I got home I had the reward notification. I clicked on it and dragged the triangle to the circle and “oops something went wrong”. No VPN going either. Waited a few and tried it again, same thing. Now the notification is gone. 1st reward that showed up for me on this browser, too :o( I hope that doesn’t continue.

1 Like

In past I was awarded the reward twice but since a month or so I am not able to claim my rewards. I am using it on android, It tells me that I have a reward to claim. I click the Claim button and it just keeps processing and finally disappears. The notification comes back after same time but if I click the button again same process repeats.

This topic was automatically closed after 30 days. New replies are no longer allowed.