No hover previews on wikipedia article links

hello, i’m recording some videos where i’m going through wikipedia and quickly reviewing specific topics but this issue which i’ve seen since i started using brave a few years ago is limiting my the quick-access hover previews.

Description of the issue:
wikipedia does not show hover previews on article links but rather only tooltips (img alt text) along with the link address in the status bar area.

the tooltip previews work only for reference tooltips when hovering over the [#] which point to a line with the reference at the bottom of the current page. these reference tooltips also bring up their own settings within wikipedia.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
hover over any wikipedia link that leads to an existing article

Actual Result (gifs and screenshots are welcome!):


Expected result: shown in safari browser


Reproduces how often:
in every instance

Operating System and Brave Version(See the About Brave page in the main menu):
macos 11.7.9
Version 1.60.118 Chromium: 119.0.6045.163 (Official Build) (arm64)

Additional Information:
is there a setting to toggle this? turned off shields, same result.

I had the same problems, And I realized if the wikipedia page you want to have a “Hover Tile” It must have a picture inside the page, and if it doesn’t have a picture it will not shat a “tile”

Left by @Vioches

apparently the linked article has images, this isn’t causing the issue.

Try turning off brave ad-blocker and brave tracker-blocker.

yes, still no change.

Try this: (1)

disabling shields unblocks all those at once, but i have also tried manually disabling them, also with no change. it appears this is not a script-reading issue, it’s the type of popup brave chooses to display, in this case being an alt-text tooltip.

i just read the console error log in the inspector, it seems brave is blocking the preview because the applet has “popup” in its name. having built-in popup blocking, it blocks all popups by default.

Screen Shot 2023-11-27 at 14.06.34

in index.js there is a number of callouts to the “popups” function. here is the first mention, pointing out that this is in fact what this issue has to do with:


Oh, ok, Learned something new

can anyone resolve this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.