No Camera detected on Zorin OS 15.3

The camera has been used for Google meet many times but since recently, I get ‘no camera detected’. However the camera works correctly with Firefox and Chromium.

I reproduce the issue by on this machine by starting a Google Meet session. A ‘No Camera Found’ message is displayed on Google Meet.

Brave version: Version 1.17.73 Chromium: 87.0.4280.67 (Official Build) (64-bit)

My Operating system: Linux (Zorin OS 15.3) 64-bit

Other settings:
brave://settings/content/camera: Enabled for the site
brave://settings/content/usbDevices “No Devices Found”
Fingerprinting allowed or not makes no difference

Hello @FrancoB

try to create new profile just for testing and see if it work there or not

hope that help and have a nice day :slight_smile:

I’ve just tried your suggestion… the new profile also does not detect the camera.

could you double check the os setting in case if the os block brave to access the camera

and could you check also the camera in brave with another site if you can

and have a nice day

Problem solved. Brave was disconnected from the camera device for some reason. To check this, in terminal run:

$ snap connections brave

This shows:
Interface Plug Slot Notes
camera brave:camera - -

I’ve reconnected manually. You do this by running this command in a terminal:

$ snap connect brave:camera :camera

This shows now as:
Interface Plug Slot Notes
camera brave:camera :camera manual

Problem solved.


well done @FrancoB and congratulations :slight_smile: