Lost all Brave passwords on update!

Description of the issue:
I just updated to Brave Version 0.70.122 Chromium: 78.0.3904.87 (Official Build) (64-bit) and my passwords are no longer there.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Update to Brave Version 0.70.122 Chromium: 78.0.3904.87 (Official Build) (64-bit)

Actual Result (gifs and screenshots are welcome!):


Expected result:
I should have my passwords!

Reproduces how often:
This was the first time

Operating System and Brave Version(See the About Brave page in the main menu):
macOs 10.14.4 Macbook Pro

Additional Information:

Anyone!? This is a really big inconvenience and I need those passwords!

Hi @cjroe – thanks for writing in. We are investigating this issue now.

cc @Mattches to follow up later

1 Like

Thanks @Asad! Let me know if you need anything!

@cjroe,
Can you try going to brave://password-manager-internals and then try logging into a website? Afterwards, share any output you see on the password-manager-internals page.

Although I’m not @cjroe, I’m having the same problem (macOS Mojave 10.14.6, running on MBP; Brave Version 0.70.123 Chromium: 78.0.3904.97 (Official Build) (64-bit); also had problem with Brave Version 0.70.122), and here’s what I got after going to brave://password-manager-internals:

Captured password manager logs are listed below. Logs are cleared and no longer captured when all password-manager-internals pages are closed.

Version: 78.0.70.123 (official)
Revision: 021b9028c246d820be17a10e5b393ee90f41375e-refs/branch-heads/3904@{#859}
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.97 Safari/537.36
App Locale: en-US
Variations:

Message: PasswordAutofillAgent::SendPasswordForms

only_visible: false

Security origin: https://community.brave.com/

Number of all forms: 0

Message: PasswordAutofillAgent::SendPasswordForms

only_visible: false

Security origin: https://community.brave.com/

Number of all forms: 0

Message: PasswordAutofillAgent::SendPasswordForms

only_visible: false

Security origin: https://community.brave.com/

Number of all forms: 0

I restarted my computer and for some reason the passwords are back. Maybe it was another update.

@Mattches Can you guys please ship the syncing feature for passwords. I really want to have a proper profile for Brave with all my crypto account, passwords, extensions, etc.

Please look at how Google does it:

https://support.google.com/accounts/answer/162744?hl=en

https://support.google.com/accounts/answer/6139018

https://chrome.google.com/sync