Latest Brave release broke Scrolling Screenshot on Android

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Scrolling Screenshot (native feature of Android 12) no longer works in Brave browser’s latest release. It worked fine until ~1-2 weeks ago.

To see the issue:

  1. Visit a webpage in brave browser on a phone with Android 12.
  2. Take a screenshot and click “capture more” when the screenshot preview shows up.
  3. The resulting page is mostly blank

After clicking “Capture More” the screenshot SHOULD contain all the page contents (text/images), just like it used it. The latest version of Chrome continues to work without any issues, on the exact same pages.

Brave Version 1.39.115

Pixel 3XL on Android 12 (no longer receiving OS updates, so the issue is with Brave, not the OS).

Please fix it!!!

@PleaseSolveMyProblem

Sure sounds like a bug for @Mattches (Brave Support) to consider. (Turns out, probably not a bug.)

Brave Browser at GitHub; Android issues with both ‘screenshot’ and ‘scrolling’:

@PleaseSolveMyProblem,
Thank you for reaching out.
First of all, I actually was not aware that this particular feature existed and I find it super useful — so on a personal note, thank you for telling me about it!

That being said, it does appear to work for me without any issue. I’ve included a couple of test screen shots below:

Can you tell me whether or not this occurs for all websites or if it is just specific websites where this feature doesn’t work? I do find it quite strange that it’s not working in Brave specifically, considering it is an OS feature.

I really, really appreciate the quick response.

Yes, the “capture more” option for screenshots is wildly useful! Glad I could introduce you to it. In some small way, it’s giving back…

I love Brave browser, I appreciate the principles you stand for, and many friends and family members are grateful to me for introducing it to them.

Did some additional testing, and some websites work correctly in Brave, but others don’t. As of about 2 weeks ago, all of them worked.

Attached is a sampler of screenshots from different sites (which I then took a screenshot of to illustrate the issue, or lack thereof).

All three work correctly in the current version of Chrome on Android (I just verified).




Interesting — while I don’t have WSJ or NYT accounts, I was able to capture the homepage without any issue:

Not sure why this would be the case but can you try doing this with Shields down for the site, just to test and see if for some reason Shields is causing some conflict here?

1 Like

Just tested. With shields down, Wall Street journal and LA times work. New York times still doesn’t… I even tried logging out, and then turning off shields. Thus, you should be able to replicate.

In addition, the original site that I use it for most often (niche professional subscription site - thus left it out when I reported) still doesn’t work with shields down.

I could probably try a few more sites and find additional examples if helpful.

Checked: https://www.latimes.com/california/story/2022-06-07/2022-los-angeles-county-sheriff-election-live-results

Does enabling Easylist Cookie list in brave://adblock help? (or disabling if its the cause).

1 Like

It doesn’t change anything. I checked the box, same behavior.