Issues connecting Brave wallet to various sites (Flexa Capacity, Squid Router, etc.)

Brave wallet is unable to connect to dApps such as Flexa Capacity (app.flexa.network) and Squid Router (app.squidrouter.com) using the method suggested on this previous Brave community forum post (How to use wallet on sites).

Clicking the MetaMask option on Flexa Capacity does nothing but produce this error: “We could not locate a supported web3 browser extension. We recommend using MetaMask. Download MetaMask here.”. On Squid Router, there is no response whatsoever. Is this method no longer applicable?

Is the issue occurring on a specific network?
Flexa Capacity is on Ethereum, while Squid Router is multi-chain but is tested not working on Ethereum or Fantom network.

Windows 10.
Brave Version 1.65.132 Chromium: 124.0.6367.202 (Official Build) (64-bit).

Additional Information:
Based on archived posts on the Flexa discord channel, Brave wallet stopped working on Flexa Capacity by at least February 14th 2023.

Hello! Click on the Injected option about halfway down the list of wallet options. This should prompt Brave Wallet. Thanks!

Thank you, I do see that as working on Squid Router, however Flexa Capacity at app.flexa.network does not have that option. Is that something they need to fix on their end or is there anything an end user can do to force the connection without an “Injected” option?

Experiencing issues connecting your Brave Wallet to various sites such as Flexa Capacity and Squid Router can be frustrating. Here are some steps and troubleshooting tips to help you resolve these connection issues:

1. Check Brave Wallet Setup

  • Ensure Brave Wallet is Properly Set Up: Double-check that your Brave Wallet is correctly configured and has the necessary permissions enabled.
  • Update Brave Browser: Make sure you are using the latest version of Brave Browser, as updates often include bug fixes and improved compatibility with web3 sites.