Installing in MX Linux


Pretty sure this issue is not addressed for folks like myself who have no command line or scripting skills, but I really like MX Linux since it provides a lot of support for the different kind of installation media that exist. What is needed from you guys is a “How To” on installing Brave in that particular distribution that does not require more tech ability than is usually had by the those folks who are just tired of all the silly bugs in Windows 10



1 Like

cc @sriram @Mattches for assistance here

Unfortunately, at his time, the only way to install and update Brave on Linux systems is by command line. However, that doesn’t mean it can’t be an easy process! Let me help you install Brave via terminal in MX Linux step by step – I’ve just done so myself:

We’re going to use the instructions for Debian/Mint 17+ instructions to install on MX Linux as it’s built upon Debian – for convenience, I’ve copied the instructions for easy reference below:

sudo apt install apt-transport-https

curl -s | sudo apt-key 
--keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

echo "deb [arch=amd64] trusty main" | sudo tee 

sudo apt update

sudo apt install brave-browser

There are five total commands to be entered here and are not as intimidating as they may seem. Note that you may be asked to enter your system password when you run a command that starts with sudo To install on MX Linux:

  1. On your system, open the “start” system menu and search for/open the Terminal Emulator
  2. Once open, type in the first command and hit enter:
    • This command is installing the required files so that you can retrieve files/resources from external repositories over https communications.
  3. Enter the next command – which is a bit longer. Afterwards, you should see an OK message:
    • This command does two things; It downloads a copy of the Brave public key
      ( curl -s ... ) which is used to sign the packages that we distribute. Then, it adds this signing key to a new keyring ( /etc/apt/trusted.gpg.d/brave-browser-dev.gpg ) that the OS’ package manager can use to ensure that downloaded brave-browser packages come from Brave Software.
  4. Another long command – after enter this command, you should get a similar message to the the one show in the image below on the next line:
    • This command adds the Brave package repository from which the signed packages can be downloaded.
  5. Almost done! Lets get those packages updated:
    • As you may have guessed, we’re updating the packages we just downloaded with this command. Your terminal will rattle off a bunch of Get's as shown in the image. When it stops, you should see the following at the end of all those Get's:
  6. Last step! Install Brave!

That’s it! Once this process completes, you Brave will be installed and you’ll be ready to start browsing! Please let me know if you have any further questions or need additional assistance.

1 Like

Hi Mattchez

Really appreciate you going to so much trouble to help me out…

  I tried the step by step several times but keep getting the

error: --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg
add -
bash: --keyring: command not found

Am I messing up here somehow?

Regards and Appreciation,


Hi @BillW
the problem seems to be that --keyring is interpreted as a command and not as a command line option. I believe that’s because of how @Mattches formatted the command.

see here

just remove one whitespace before --keyring, so it does look similar to that

Or copy and paste this instead:
curl -s | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -
which should format it right.


  Thanks I finally caught on to how to enter the commands and now I

have Brave installed in MX Linux…

  I really appreciate all your patience and help for an old codger

that really loves MX Linux and Brave… But just not very good

the command line stuff…


Bill W

OOPs guess I was a little hasty in my assessment of the situation. The Icons are there but they will not start the browser… is there something else I need to do?


Glad you got it working and thank you @leon0402 – definitely was the formatting, that’s my bad.
You should be able to start the browser from the icons – did you pin it to the task bar?
Additionally (since you’re a command line aficionado now :slight_smile: ), you can start Brave from the command line by typing the very long command


If it launches from the terminal, you should be able to pin it to the task bar and use that shortcut to open it every time.

Hi Mattches…

This all seems a little like magic to me…
All of a sudden the Browser is working…
Thanks for your patient efforts…




You’re very welcome :slight_smile: