Extensions Bug in Update V1.25.70 or .68 (May 27, 2021)

Extensions Bug in Update V1.25.68 or .70*

Description of the issue:
Extensions that were previously pinned in all Brave versions up to V1.24.86 appear as they should. Since the V1.25.68 or .70* update, only the puzzle piece (extensions) icon appears - all the previously-pinned extensions are missing.

In the update, when I click on the puzzle piece, I can see the extensions but the pin button is greyed out, and I can no longer pin any extensions. In order to use the extensions, I must do so from inside the Extensions menu. I’ve dug around inside each extension; changing settings from within the individual extensions has no affect. The only thing that has worked has been to install the previous version of Brave each time I want to use the browser. The last version that worked was V1.24.86.

How can this issue be reproduced?

  1. Open browser, update to Version 1.25.70 Chromium 91.0.4472.77 (Official Build) (64-bit). Close and reopen browser.
  2. Observe no extensions are pinned.
  3. Open Extensions tool (puzzle piece icon) Try to pin an extension, but pin is greyed out.

Expected result:

  1. Open browser (any version)
  2. See existing extensions pinned OR open Extension Tool and try to pin extension. Pin icon should turn RED indicating extension was successfully pinned.

Brave Version( check About Brave):
*Good Question. When I check About Brave, it says:
“Version 1.25.70 Chromium 91.0.4472.77 (Official Build) (64-bit)”
BUT when I click on that,
it takes me to https://brave.com/latest/ which shows as " Desktop V1.25.68 (May 27, 2021).

Additional Information:
I am able to re-
install V 1.24.86 and restore the functionality of the previously-pinned extensions; they immediately appear as they were before on the browser. I am also able to pin other extensions from V 1.24.86. As soon as the browser is updated and reloaded, the pinning function is broken.