Error on linux pop os 20.04 sudo apt update

Hi guys, I am running pop os 20.04, Getting straight to the problem.

When I run “sudo apt update”, I get the following error:

W: GPG error: focal InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 4FE13824E3FFC656
E: The repository ‘ focal InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I have referred to - Installation issue (ubuntu 18.04.3 LTS), but I get different outputs after executing the commands given in solution by fmarier

Here are the commands with results:

~$ ls -l brave-core.asc
-rw-rw-r-- 1 shash shash 3914 Dec 3 12:49 brave-core.asc

~$ sha256sum brave-core.asc
c8fe807da94fbdabea5cb394630e11ef5a57ba0163e5c37e8e873c80602acb78 brave-core.asc

Note: There is an “rw” instead of “r” in first output and the string is completely different in the second output.

fmarier said, “If you’re getting a different size or a different sha256, can you try downloading using a web browser and saving to a file. Then you can check the file size and run the sha256sum command again.”.
But I am a novice and so couldn’t do it without step by step instructions. I ran the other commands given by fmarier in the post anyway but the error remains.

P.S. This error screwed up my Pop Shop too, so I can’t upgrade my other software either.
Thank you in advance for your time.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.