Hai, I Just started using Linux (Ubuntu) and i installed brave few days ago. I always get this error when i try to update or upgrade my OS/Software

ERROR DURING UPDATE

W:Updating from such a repository can’t be done securely, and is therefore disabled by default., W:See apt-secure(8) manpage for repository creation and user configuration details., W:GPG error: https://brave-browser-apt-release.s3.brave.com stable InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY A8580BDC82D3DC6C, E:The repository ‘https://brave-browser-apt-release.s3.brave.com stable InRelease’ is not signed.

Hi, did you follow these instructions? https://brave.com/linux/

Make sure especially to do the part involving importing the ‘brave-browser-archive-keyring.gpg’ as this key will be used going forward to verify the integrity of the downloaded packages, prior to installing.

I’m not an Ubuntu user but based on the error it looks like that’s your issue. If you did that and it still fails let us know, or show the output of the entire installation process listed on the link above.