Download link for installing brave linux is broken

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
How can this issue be reproduced?

  1. type in an existing browser: https://brave-browser-apt-release.s3.brave.com

Expected result:
is to have access to the install repository for brave
Brave Version( check About Brave):
for Debian 9+, Ubuntu 14.04+ and Mint 17+
Additional Information:
Worked in earlier times, now i am getting:
NoSuchKeyThe specified key does not exist.index.htmlF79E92D8F5D44E0FMAdXDBYzIID/oS/1eBZP5cfVwHw3zQm02zj44EtFvdSDs50od2yoypzqaiDlbPlVWTo2l7iQL9E=

1 Like

You can find the correct URLs for the Linux repositories at https://brave.com/linux/.

I agree that the page you link to above could be more helpful, but there is nothing hosted there directly.

1 Like

you should use package manager
debian based: sudo apt install brave
arch based: sudo pacman -S brave
RHEL bases: yum install brave
or download, extract and type:
makepkg -si or sudo make or sudo make install

Yoge67855

Thank you for your reply

My OS: knoppix 8.6.1

  1. I typed:

sudo apt update

sudo apt install brave

and get the following:

Reading package lists… Done
E: The value ‘stable’ is invalid for APT::Default-Release as such a release is not available in the sources

CLEARLY THIS IS NOT A SOLUTION!

I also AGAIN went through the install steps for debian 9+. No success. “Unable to locate package brave-browser”

  1. With reference to:

or download, extract and type:
makepkg -si or sudo make or sudo make install

where do i download from? brave.com/linux/#linux mentions the same install procedure for debian linux > with ‘broken link’:

AWAITING FOR VIABLE SOLUTION STILL…

Any deb packages that i can download for this browser?

Stephen

blocked.gif

Hi Francois

My OS: Knoppix 8.6.1

In terminal:

uname -a

Result: Linux Microknoppix 5.3.5-64 #16 SMP PREEMPT Wed Oct 23 02:08:38 CEST 2019 x86_64 GNU/Linux

dpkg --print-architecture

Result: i386

So with a 64 bit kernal and a 32 bit reading what is Knoppix??

Brave clearly supports amd64 (64 bit) only!

https://brave.com/linux/ only provides the install steps with the following source >

https://brave-browser-apt-nightly.s3.brave.com/

Stephen

blocked.gif

then try:

sudo apt install apt-transport-https curl gnupg

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

echo “deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main” | sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update

sudo apt install brave-browser

for beta, dev or nightly
but instead of
sudo apt install brave-browser
you type:
sudo apt install brave-browser-beta
or
sudo apt install brave-browser-dev
or
sudo apt install brave-browser-nightly

Hm, that’s weird. It does look like you are running a 64-bit kernel on a 32-bit distribution.

While we only support 64-bit distributions, you might be able to add amd64 as a foreign architecture and then install the brave-browser package as a “foreign” 64-bit package. I’ve never tried it myself but https://blog.zugschlus.de/archives/972-How-to-amd64-an-i386-Debian-installation-with-multiarch.html suggests that it might work.

1 Like

Hi yoge67855

I tried the steps you gave me and no success.
I did the following in terminal:
1)Uname -a
2)Dpkg --print-architecture

Result:
1)–amd64 kernel
2)i386

So it seems my OS (knoppix 8.6.1) uses 64 bit kernel with 32 bit architecture. How do i add brave as ‘foreign’ package?

Regards

Stephen