Developer Tools - devices choice no longer being saved


When using Developer tools, and using ‘Toggle Device toolbar’, any changes made to the devices list are not saved.

This feature was working until about middle of January.

Now, when browser is closed, the ‘device list’ reverts back to default selection.
There seems to be no way to save my device selection (or any ‘custom devices’) I have created.

Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)

Windows 10 Pro version 20H2

5 Likes

Same issue here.
Seems like, every time you open a new Tab or restart the Browser, the file %homepath%\AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\Preferences will be overwritten with a default version.

1 Like

tiggalot is correct. What’s the point of ‘User Preferences’ that get overwritten with default data? Is there a way to bypass this behaviour?

1 Like

I am a web developer and I need a non-mobile device in the list of emulated devices, but now I have to add a new custom device every time I close the dev tools, because my created devices are lost every time.

1 Like

Bumping – this is not the only devtools setting being lost.

1 Like
2 Likes

Same issue here. Doesn’t seem to be happening on latest Chrome version.

1 Like

Incredibly annoying, was hoping the latest update would fix it. It’s not even just on browser close for me, as soon as I close the Inspect mode it clears any stored devices.

Luckily I only have to emulate one device size, but that’s already driving me mad for development.

1 Like

Just tested in Chromium in Ubuntu 21.10

Version 97.0.4692.99 (Official Build) snap (64-bit)

and the devices choices are persisted so this seems like something specific to Brave.

My current Brave version is

Version 1.34.81 Chromium: 97.0.4692.99 (Official Build) (64-bit)

Bump. I’m having the same issues. On window close, preferred device tools resort back to the defaults. Pretty rough after selecting the devices I’d like emulated and adding 4 custom devices.

Same problem here. I’m using a Mac and I’m not able to save the responsive breakpoints.

+1 I can’t save my ignore list patterns, they get wiped at restart.

Same issue here. Devtools settings keep being reset upon new tab / browser restart.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.