DeepL Translator Missing After Brave Update

Description of the issue:
How can this issue be reproduced?

  1. Right click select Japanese text, there used to be DeepL translate option before update of Brave on April 10.

Expected result:
Expected to see DeepL translate the text.

Brave Version( check About Brave):
Brave is up to date
Version 1.50.114 Chromium: 112.0.5615.49 (Official Build) (64-bit)

Additional Information:
I added the DeepL extension two months ago and it has worked flawlessly until Brave updated this week. Now there is no DeepL option to translate foreign text.
I can only type English text and translate it to Japanese, but I can’t select Japanese text anymore and have the option to translate to English. I have to copy and go to the DeepL website and paste the text now to get translation. Used to happen in browser before last night.

@Basspig I’ve been using DeepL and it’s still there. Should be no reason it would just vanish. You haven’t created a new profile or have it disabled under extensions, right?

Btw, other thing to let you know is when I spoke to DeepL about issues and limitations with their app, they advised me to add their program. So I’ve had both. The program helps a lot on translating, especially for anything I want to write. You can see that at Just wanted to mention in case you wanted to check it out.

As it turned out, I had to uninstall DeepL and reinstall it to get back functionality. It is working now.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.