Connecting Nano S Ledger to Brave wallet : some tokens does not appear

some ERC20 tokens (USDT) appear in Brave wallet
some ERC20 tokens (Lido staked ETH) does not appear

@puiseux not all tokens are automatically visible within Wallet. Sometimes you have to add the asset yourself for Wallet to see them and show it to you.

You’ll likely have to manually add it and make it a visible asset. You can do that via instructions below:

Or as I share in the FAQ here on Community:

Some may be listed under Available Asset and need to just be enabled, while others will require you to provide things like the token contract details and all to become visible.

OK, I added the new asset to Brave wallet (STETH is the gecko symbol for this asset). After that, it looks like if Brave Wallet knows it, but does not detect it in my Nano S Ledger… Despite the fact i close and re-open the Brave wallet.
Well, maybe I did not fill correctly the field “number of decimals” for the asset. But … How to correct this ?