Can't link my Gemini Account to brave wallet

Briefly describe your issue:
I have been trying to link my Gemini wallet to brave but it keeps giving me an error.
What Operating System and Brave version are you using (Menu --> About Brave)?
MacOS and [
Version 1.35.103 Chromium: 98.0.4758.102 (Official Build) (x86_64)

Is your browser wallet currently verified? (yes/no)
no
What date did you verify your wallet?
May 10, 2022 but not verified yet
Have you been able to successfully receive payments in the past?
no
Are you using a VPN? (yes/no)
no
Are you in a supported region (see here for list of supported regions)?
Yes, United States

Nor uphold. Looks like it went from not paying ads to disconnect wallets

1 Like

Before going further, could you confirm if you have any update available for MacOS? I see that you are using version 1.35. Version 1.38 should be available already.

Second, confirm in the post below if you are in a supported country.

1 Like

@iamsaugat,
Also what error is it that you’re seeing?

Same is happening in Croatia, camt connect to Gemini and Croatia in NOT on the list diabled countries.I trying for few days alrdy