Can't get the automatic translator off

Description of the issue:
Google translate keeps insisting on translating a website I’m visiting, stylevana (a skincare shop), and I can’t seen to shut it off, no matter how hard I try. It doesn’t do this on other websites I visit, or at least, I haven’t come across them/I don’t remember them.

Steps to Reproduce.

  1. I’ve tried turning the automatic translation in settings off, it was already off.
  2. I’ve stopped the extention of google translate, didn’t work, I removed it, didn’t work.
  3. I’ve noticed in the url there was a html?googtrans=nl thing, removed the googltrans=nl part and hit enter, didn’t help either. It seemed like it just took longer to load.
  4. Updated Brave to it’s latest version. Didn’t work.
  5. I’ve clicked on the downwards ^ and ticked the, don’t translate on this website option. (Didn’t do it either.)
  6. Brave is now in English, I thought maybe it’ll now translate to English. (It didn’t, still Dutch.)
    ‘English (United Kingdom)
    This language is used when translating pages
    This language is used to display the Brave UI’

Actual Result:

Expected result:
I expected the automatic translation to stop by now.

Reproduces how often:
Every time I click on something on that website it translates again, not immediately, after a second or so.

Operating System and Brave Version(See the About Brave page in the main menu):
Brave is up to date
Version 1.29.76 Chromium: 93.0.4577.58 (Official Build) (64-bit)

Additional Information:
Chrome works fine (on not translating the stylevana website). Brave on mobile phone works fine too. I’ve used stylevana before (with Brave on pc) but this wasn’t an issue before. Don’t know what changed. I would prefer to use Brave. (I installed Chrome for times when Brave isn’t working.)

Have you tried clearing cache/site data fo the site in question?

  1. Visit the site
  2. Click the “lock icon”
  3. Site settings
  4. Clear data

I haven’t. But oddly enough… It seemed to just have stopped? Just this minute, right after posting. Didn’t do anything. It’s like magic. I’ll try the clear data one for next time though. I’m baffled but delighted.
Edit: Oh right, there was one thing, I saw the non translated page but with a similar translate bar, then told them again to not translate this page and lo an behold, it actually didn’t!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.