Can't Copy Text In Private Window Mode After Latest Update

Just updated Brave (Desktop, Windows 10) to

Version 1.65.114 Chromium: 124.0.6367.60 (Official Build) (64-bit)

Now cannot copy text from any Website I’ve tried in a private window. I can, however, copy text from every site that I’ve tried when running in a standard (non-private) window. I’ve tried restarting Brave, restarting Windows (V10), turning off Shields, turning off all extensions, all to no avail. Considering I do 99% of my browsing in private windows, this pretty well kills using Brave for me.


@Willikens just wanting to clarify, is it not letting you right click and copy or are you just trying to use Ctrl+C? And does it matter if it’s trying to copy from the site compared to copying from text input boxes?

I’d also like to ask, does it have the same issue if you were to create a new browser profile?

I tried to replicate your issue on my Windows but it doesn’t seem to be having issues.

Thanks for your reply, @Saoiray.

I’ve just spent the last hour or so digging into this further before responding. It appears to be an issue with the Windows 10 clipboard history function, not an issue with Brave.

I have the clipboard history turned on and I tend to make extensive use of the history function. Normally, copied text shows up in the history after pressing WinKey+V. Following the update to Brave, after doing a CTL-C in a private window, the copied text wasn’t showing in the clipboard history list. Further testing shows that this issue exists not only with Brave, but also Edge, Chrome, and even Firefox. Curiously, however, the problem does NOT exist with Vivaldi (yet, anyway). Also of note, I discovered that while the most recent copy operation (from a private-mode window) doesn’t show in the clipboard history, it does, in fact, exist. IOW, a CTL-C followed by CTL-V pastes the most recently copied text.

I’ve tried deactivating/reactivating the clipboard history function in the Windows settings but that didn’t solve the problem. So - I have no idea what happened. At the time Brave updated, Edge also updated. No Windows updates occurred (most recent being April 9).

Bottom line: It appears to be a problem related to Windows and the clipboard history. It’s extremely unlikely it’s a Brave-caused issue. The interesting bit is why is whatever happened affecting Brave, Edge, Chrome, Firefox but not Vivaldi.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.