Cannot share or record screen within Brave

Description of the issue:
When using ANY video call tool, like zoom, if I share my browser’s window all participants see is just a black screen. I can share other app’s windows without issues.

Likewise, when I want to record a screencast of my browser, the result is just black. I tried with many options and I normally use Kazam. I can record anything that happens outside Brave, but within Brave the only thing I get is a black screen with the mouse moving.

Note: On my end I DO SEE the browser, the problem is that other participants of web calls don’t. Likewise, when I record my screen, I see what I’m doing, but when I check the video I just see the mouse moving on a black screen.

Tried with hardware acceleration enabled and disabled, this doesn’t change the behavior.
It has been like this for several months, so the Brave version is not that relevant.

How can this issue be reproduced?

  1. Open zoom and share your screen with other participants
  2. Ask them if they see it


  1. Install a screen recorder like Kazam
  2. Start a screencast and open Brave
  3. Stop it and check if the video shows the window’s content or just a black screen.

Expected result:
See Brave’s windows

Brave Version( check About Brave):

Additional Information:

  • Ubuntu 20.04
  • Ubuntu 21.10
  • Ubuntu 22.04
    Same behavior.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.