Cannot download from one website

I am trying to download the daily podcast from and I get this box:
image…when I click on ‘keep’ another box pops up at the top:
image…when I click on ‘keep anyway’ nothing happens. The only thing I can do is close both boxes. I have tried completely reinstalling Brave, but it still does the same thing. Is this a glitch in this latest version?

Actually, you can download.

But there is some reason for caution. Reasons may be:

Maybe / possibly / you may find out . . .


The “Standard Protection” setting (when enabled), might be sort of, kind of, letting Google know . . . and whatever that “protection” function is, may be warning you (that they maybe sort of object)?


Sometimes, portions of a webpage are secure, but other portions are not, and the tiny icon at the left, inside the URL field, will change from being a PADLOCK to a RED circular field with a WHITE exclamation point in it.

This may also be due to an extension you have installed in the browser causing a conflict with the downloads. If you have any extensions installed, can you please try disabling them and testing again?

I have disabled my extensions and disabled all the security tabs and still no dice. I have also done a clean reinstall of Brave using an offline copy. I have no problem downloading from another browser (PaleMoon) so its not an external problem. It seems to be some blacklist or bug in Brave. It seems to have started with the latest upgrade so hopefully they will fix this in the next iteration. I have a workaround -I use IDM which is actually faster and more reliable because I have the world’s worse dsl service here. So far, this is the only site I have problems with so not a big deal. Thank you for your replies- maybe someone else is experiencing this too and will post an answer.

My guess is that for one reason or another, that site is triggering the built-in Safe Browsing which prevents the download. However you should still be able to select Keep anyway to download the file. Can you share the website in which you’re downloading these files from?

I brought up the website and clicked on the padlock in the search bar. The drop down box presented ‘site settings’ which took me to permissions for that site. It had ‘insecure content’ blocked. I set it to ‘allow’ and problem is solved. Thank you guys for pointing me down this path.


Great sleuthing. Glad we were able to get that resolved. Don’t hesitate to reach out if you have any additional questions.