Can Someone help fix my crypto wallet

I have been using an exchange called uniswap and i thought my wallet was connected through metamask but turns out i had been using the crypto wallet on brave browser. I had also connected my metamask wallet to uniswap creating a conflict of interest with the two active wallets. I ended up trying to make a swap of tokens on the site and nothing worked at all. now i have 22 pending transactions i cannot cancel in my crypto brave browser wallet

1 Like

@col - sorry to hear you’re having these issues.

Can I ask the nature of the swaps you were doing? Ex, what asset to what asset were you trying to swap? Thanks

1 Like

I was trying to swap wrapped ether into MTA or meta. I do not think the use was with the assets i was swapping. I believe it had to do with the two wallets being connected at the same time cause all of the transactions to fail. but it kept all of the attempted transactions as pending in my crypto wallet effectively bogging my wallet with 22 failed transactions pending still. I am unable to cancel any of the transactions manually or send the tokens because even though the transactions were dropped from the network it still says pending within the wallet. @ryanml

*issue instead of use in the second sentence

I’ve got a similar issue using uniswap. Uniswap recognizes my Brave Wallet and I can’t figure out how to get it to use my Metamask Wallet.

got to setting scroll down to extensions and for web3 provider for dapps change the extension from crypto wallet to meta mask. then you should be good to go. @fivestartech

2 Likes

Hello!! same problems with metamask and brave wallet… mintr and metamask makes me ETH and SNX bug. 200$ locked. Trying to cancel transaction… no succes!

capture|690x468

Brave used to connect to Uniswap by default, but not anymore after I removed Metamask. do we need to have metamask installed to be able to connect to cryptowallets and Uniswap?

Does anyone help people here or are there just a bunch of posts that never get resolved. I am having the same issues and would like to see it resolved.

Hello Sethandcamille.

I solved the problem by myself. In fact not complicated at all. Go to settings, then advanced settings, and then select “reset account”. This will reset blocked transactions without erasing the account.

awesome ty. There seems to still be a problem with the link between metamask and the brave wallet though. I have 5 eth in my wallet but metamask still says that there is 0 eth there. There is a problem with my WEB3, metamask, and brave browser not communicating right. Which one is screwing up, I don’t know yet.

Oula much worse than me indeed. I had ETH and tokens blocked on a site, but they did not disappear. Unfortunately, I will not be able to help you further. Just that in my opinion ETH does not disappear like that, on ETHERSCAN the wallet must still be credited with ETH. Otherwise to check, on the off chance, in the “extentions parameters” in brave, check what is the default crypto wallet? deactivate / reactivate

I’ll try that I guess. Nothing else has worked.

ya it was just a simple switch from metamask to cryptowallet. I don’t know why I had it switched to metamask but it seems like that is what the problem was. Just changed that and restarted brave and it seems to be working now. Lets see if I can move any eth now.

Tik defaut “metamask” and i think it was good.