Browser install gets stuck on "on your marks.."

Description of the issue:
I’m trying to install Brave on 2 laptops. One had a flawless installation and the other just gets stuck on “on your marks…” in the installation. Both of my laptops have Windows 10.

On the laptop where it doesn’t install Brave, I tried the following:"

  • Installing the 32bit version
  • Installing the standalone version
  • Using a VPN during install
  • Deleting all existing Brave folders and files I had from my previous time using it a year ago and installing it again
  • Turned off windows anti-virus and firewall

All without success. Does anyone have other methods to try? I couldn’t find much on this issue online.

How can this issue be reproduced?

No clue since it didn’t happen on my second laptop.

Expected result:

For it to install so I can use Brave across all my devices.

Brave Version( check About Brave):

Latest install

Additional information:

Shot in the dark here, but are you behind a proxy (business, parental control, etc.) by any chance? I’ve seen instances of proxies thinking the Brave version # was an IP address and it interpreted that as a callout to a ‘malicious’ (bare IP, no domain name) site and blocked it. The installer behaved very similarly to what you’re seeing.

I may not be able to follow up again for a few more days, but if you can’t get past this and just want it installed, you can grab a ‘Standalone’ installer (doesn’t need Internet access to do the install) from the Brave GitHub repo. Just make sure you get it from the correct version #.

If you go that route, just keep an eye on things for the next version or two to make sure it’s auto-updating. There isn’t any intrinsic reason it shouldn’t, but whatever is causing your current issue might likewise cause auto-updates to fail.

I’m not behind a proxy and tried using a VPN to see if it was my connection and it didn’t work. The standalone install didn’t work as well but not sure what version I tried. Will try the latest one available on Github without an internet connection.

I’ve now tried to install the standalone version without an internet connection.

The versions I tried from Github are:

  • Release v1.32.106 (BraveBrowserStandaloneSetup+BraveBrowserStandaloneSilentSetup)
  • Nightly v1.34.35 (BraveBrowserStandaloneNightlySetup)

Still getting stuck at the same part in the installation. Silent setup just kept going in the background till I closed it via task manager.

@StefVDM,
Very strange behavior. To be clear, you’ve tried installing Brave both on and off the VPN connection?

Yeah, both. Even tried installing it completely offline.

@StefVDM,
Can you double check and confirm that nothing is blocking updates.bravesoftware.com and/or laptop-updates.brave.com on your system?

Where can I exactly check this? I’ve checked the firewall settings and nothing related is in there. I’ve also pinged the addresses above to check if those IPs were blocked and they weren’t blocked either. I really have the idea that I tried everything at this point.

It would depend on what security software you’ve got installed. It sounds like it’s MS Windows Defender included with Windows? I wouldn’t normally expect Defender to have an issue here unless it’s been heavily modified, but we can come back to that if necessary. Short on time atm, can follow up more later if necessary. Found some other ideas here though: https://support.google.com/chrome/thread/41212037/google-chrome-installation-stuck-on-on-your-marks?hl=en

There are some ideas there, I would be very careful with some of them, but the ‘troubleshoot compatibility issues’ one sounds interesting.

Also, any chance you’re trying to install it thru some kind of remote access tool, such as Remote Desktop? Or are you at the physical screen/keyboard of the system itself?

I’ve seen this thread before I posted mine here and tried most of the methods people suggested. The troubleshoot didn’t work and the running as admin thing didn’t work. I am at my laptop myself and do not access it via remote access.

The only thing I haven’t tried yet is deleting all files of my current google chrome setup but I’m scared I won’t be able to get back to my chrome after I uninstall that. Since I need chrome for work.

@StefVDM,
When installing Brave, can you check you task manager and ensure that there are no other Brave or Chrome processes running in the back ground via your Windows task manager?

Exactly the same thing here, I’m stuck on “on your marks." screen.

@StefVDM , I know you mentioned there’s no proxy involved, but I think you’re saying this is a work/corporate device? And you mentioned a VPN. Is your Internet connectivity managed somehow by your employer? If so, they could be blocking something and might be worth asking if they can look at their logs.

(Also, in particular if it is a business device, there could be a completely transparent proxy in the path.)