Browser does not display any websites in Windows 11

I used to use Brave browser in Windows 10 but since “upgrading” to W11 it will not display any websites. I’ve uninistalled and reinstalled many times, even as admin, and still cannot get anything to display. When I first open the browser it automatically goes to:

and I get the following error:

If I try to change the URL, for example to, it reverts back to the original URL above. When I open a new tab, it is blank in the URL bar and I get this displayed:

This time when I enter a new URL,, I get nothing but a white screen displayed - no error message, nothing.

When I go to “About Brave” in the drop-down menu, the URL shows: brave://help/
But once again, I get only a white screen.

All of my other browsers work: Edge, Firefox, Google Chrome, even iTop Private Browser.

I’m running the following on my desktop PC:


Any ideas on why this is happening?

Well this doesn’t make a lot of sense to me right at the moment because I’ve been running the same security software for several years now but I ran into a problem with it so I did a full uninstall and just as a test I tried to open my Brave browser and it worked perfectly. I did not set the security software to block it so for some for some reason it started blocking it from displaying websites. I’m going to reinstall my security software and see what happens but for now, Brave browser is working.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.