Brave suddenly not displaying images from imgur/ebayimg, potentially others

This has been a sudden issue for me. Everything worked fine a few days ago, but then suddenly everything from imgur began showing broken image logos. Today ebayimg followed suit.

To my knowledge I have changed nothing to cause this behaviour.

I am running Version 1.10.97 on Win10 and am up-to-date. I do run a number of extensions, but the problem persists with the extensions individually disabled and Brave restarted and in a private browsing session with no extensions enabled.

While I am connected via VPN normally, this behaviour persists when connected or disconnected via VPN. It also persists whether I am browsing through Pi-hole DNS or Google/Open DNS. The problem also persists with/without Brave Shields.

Tellingly, imgur/ebayimg and all other sites work fine when using Firefox or Edge. This problem seems to be localized to Brave. It also seems to be inconsistent: Sometimes ebayimg will load, and even imgur.com (via Reddit) worked for a couple hours yesterday before it re-broke itself.

I’m not seeing major reports of this from other users, so I’m guessing it’s something unique to my machine or configuration.

Shy of reinstalling and losing all of my preferences, does anyone have any suggestions for what might be the problem?

Cheers!

And weirdly, now everything’s working. I’ve changed nothing, and am confused.

And now ebayimg is back to not working again. This is really frustrating. Anything?

Hi @underscore-hyphen, Welcome to Community!
Can you try creating a new test profile and seeing if the issue persists?
Click on the menu icon in the top right corner > create a new profile.

imgur is back to working. eBay, including all of eBayimg, does not work even after having created a new profile and not importing any bookmarks/plugins/settings.

What occurs when you visit ebay.com @underscore-hyphen ? I logged in and checkout a few auctions on the site. Does using private window mode help?

This is driving me nuts! Today ebay.com displays all images. Yesterday it displayed none.

When it doesn’t work, it universally doesn’t work: Brave Shields down, private browsing window, new profile, etc.

I’m very confused. This is limited to Brave, but it happens irrespective of connecting to VPN and it doesn’t happen with any other browser on the machine.

I think maybe it’s possessed.

1 Like

ebayimg is back to not working, though imgur is functioning as normal.

eBay worked fine for me literally an hour ago and I’ve changed no settings in the meantime.

At this point I’m not expecting a solution, I’m just documenting the frustration for future generations.