Brave randomly adds sites to it's new tab page that were a part of my recent browsing history

Description of the issue:

Brave randomly adds sites to it’s new tab page that were a part of my recent browsing history

How can this issue be reproduced?

This issue occurs randomly, so I’m not sure how you can reproduce it all the time. However, I’ve found that one way to reproduce the issue is to log on to the web version of Twitter using Brave. When you log on to the web version of Twitter using Brave, Brave will show you a small banner near the bottom of the browser’s screen. The banner offers to add Twitter to your phone’s home screen. When you dismiss the banner and go back to the new tab page, the web version of Twitter (and sometimes the sites that you have visited before you visited the web version of Twitter) will be added to your new tab page.

Expected result:

I never expected anything to occur. I only wanted Brave to not add stuff to it’s new tab page unless I say that it can

Brave Version( check About Brave):

1.17,75, Chromium 87.0 4280.88

Mobile Device details

I use Android 10 on my phone. My phone’s model is an LG G8 ThinQ.

Additional Information:

This issue did not occur in the past for me. It only started occuring after I reset my phone, upgraded it’s OS from Android 9 to Android 10, and reinstalled Brave. Please fix this issue in a future release of Brave. I sometimes let other people use my phone, and when Brave randomly adds parts of my browsing history to it’s new tab page it puts what I search for on the web on display to my friends and family.

Did you mean this (orange box)? You can remove it from 3 dots menu (pink box)

1 Like

That is not what I mean. My issue is with sites randomly being added onto the new tab page itself, not in the widget bar that displays on top of the new tab page

Ah, so based on your screenshot, I disabled my NTP settings (Settings > New Tab Page Settings).

FYI, it’s the same “Top Sites” feature. The old design. Appears if you’ve no widget and background image.

You can “remove” it by going to Settings > New Tab Page > Widget Stack > Add “Privacy Stats” widget.

And it should appears like below


Thank you! This fix seems to be working for me.


This topic was automatically closed after 40 hours. New replies are no longer allowed.