Brave not working properly in Windows 11

Description of the issue:
I just changed computer and it came with Windows 11. Brave opens up but not all the information is showing up. ometimes, when I move my mouse, some fields will appear, but never all the page. I have uninstalled and reinstalled both versions many times.
Strangely, the beta version correctly twice, I am not sure after what operation, maybe a reboot. But rebooting doesn’t work now.

In Windows 11, I have no option to turn off the default setting for hardware accelerator as some have suggested to do.

How can this issue be reproduced?
It is still not working. And I don’t know the cause…

Please help as I love Brave and I am very sad to have to default to any other one…

Expected result:
A working browser !

Brave Version( check About Brave):
Brave Beta and latest version of Brave as I downloaded it again just today.

Additional Information:

Thank you for any type of help.

HI, thank you so much for your answer. I can’t do anything from inside the browser itself cause no fields are showing up on the page… it’s pretty much empty. I am not sure if you can see the image below, but this is an example of what it looks like.


I hope we can find the solution!
Thank you again


1 Like

Hi and thank you again for your help.

Something really strange happened. As you suggested, I right clicked on the Brave icon desktop and didn’t see any option to run with a different processor. But I saw an option to “Troubleshoot compatibility”, and I tried it. I answered a few questions and selected:

1- Troubleshoot program
2 - Program not displaying properly
3 - And then I tried a few different options as mine didn’t show up exactly.
4 - When I tried “the program doesn’t display properly when large scale font settings are selected”, it applied this setting to the browser and it became normal again !

So it works now!

Thank you for that suggestion!
Have a wonderful day


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.