Brave keeps coming up with "Sorry, that page is missing" on random websites

But it’s not! The page I want is always there, it doesn’t give a “404”. This is happening on many different web pages (but not all), too many to post. Up until now I’ve been ignoring it and clicking on the “x” to close it, but it’s getting annoying! I looked through the settings but nothing stood out. I tried clicking on the “Check for saved version” icon for the first time to see what happens, but it just disappears when I click on it. How do I get rid of this?

Does the site work as expected when using Chrome?
Yes

Brave version (check About Brave):
Version 1.23.73 Chromium: 90.0.4430.85 (Official Build) (64-bit)

Which websites @ImNotGeorge ?

Not enabled secure DNS in brave://settings/security?search=DNS ?

“Use Secure DNS” is ON. Below that, the button is selected for “With your current service provider”.

Too many websites to keep track of all of them that come up with that message, but a good guess is at least half of the ones I visited.

Is that happening during something like Cloudflare bot detection or some similar system, or when using the search function on some sites? If so, the Brave think that that page doesn’t exist.

@ImNotGeorge,
Can you try disabling “Help tips” – Brave’s built-in wayback machine feature – and see if you still get those same messages?
Settings --> Advanced --> Help Tips

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.