Brave doesn't support SOCKS5 authentication

When I attempt to use an extension to use a SOCKS5 proxy the extension warns me that my browser doesn’t support SOCKS5 authentication. This is a little ridiculous.