Brave browser won't open on debian 64bit

Description of the issue:
Title
Steps to Reproduce (add as many as necessary): 1. 2. 3.
I tried installing both brave and brave-beta following the instructions reported here


Actual Result (gifs and screenshots are welcome!):
If I click on the browser icon from the app launcher it won’t open
Expected result:
should open
Reproduces how often:

Brave Version(about:brave):
latest 0.23.100-1 0.25.2-1
Reproducible on current live release (yes/no):
idk
Additional Information:
debian 4.9.0-8-amd64

1 Like

Hi @0xcrypt,
You may want to try this instead https://brave-browser.readthedocs.io/en/latest/installing-brave.html#linux

Brave 0.25.x is the latest version for soon-will-be-replaced Brave (muon).

Brave is in migration process to new architecture. And unfortunately, this version will no longer receive a bug fixes, etc. Since this version will be replaced by the new Brave (0.56.x and higher). https://brave.com/new-brave-browser-release-available-for-general-download/

Ah, my bad. Thanks for the quick answer. I did follow the steps in the link you posted but it still won’t open

Installation log looks fine

sudo apt install brave-browser
Reading package lists… Done
Building dependency tree
Reading state information… Done
Recommended packages:
libu2f-udev
The following NEW packages will be installed:
brave-browser
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 62.8 MB of archives.
After this operation, 213 MB of additional disk space will be used.
Get:1 https://brave-browser-apt-release.s3.brave.com stretch/main amd64 brave-browser amd64 0.56.15 [62.8 MB]
Fetched 62.8 MB in 2min 19s (451 kB/s)
Selecting previously unselected package brave-browser.
(Reading database … 141293 files and directories currently installed.)
Preparing to unpack …/brave-browser_0.56.15_amd64.deb …
Unpacking brave-browser (0.56.15) …
Setting up brave-browser (0.56.15) …
update-alternatives: using /usr/bin/brave-browser to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
update-alternatives: using /usr/bin/brave-browser to provide /usr/bin/gnome-www-browser (gnome-www-browser) in auto mode
Processing triggers for mime-support (3.60) …
Processing triggers for desktop-file-utils (0.23-1) …
Processing triggers for menu (2.1.47+b1) …
Processing triggers for man-db (2.7.6.1-2) …

@0xcrypt
Looking into this now, thanks for reporting. Will reply with more information.

@0xcrypt, did you install using these instructions?:

I ran into several issues as well, the Snap only wanted to run after setting snap core to the beta channel, but the regular .deb usually worked on Debian/Ubuntu-based systems.

Does it give any error messages when you start it from command line instead of clicking the app icon?
Usually it complains about Sandbox issues etc. but starts nevertheless, but it might say something useful in your case… :smiley:

0xcrypt,
You should be able to launch from the Terminal, use brave-browser --no-sandbox. Additionally, it looks like there is an open issue for this with a potential workaround:

Update,
Can confirm that the workaround does the trick. Use:

sudo sysctl kernel.unprivileged_userns_clone=1 
echo kernel.unprivileged_userns_clone = 1 | sudo tee /etc/sysctl.d/00-local-userns.conf

To set user sandboxes. This should allow you to launch the app via shortcut.

3 Likes

Yep it works now. Im getting this from terminal

ATTENTION: default value of option force_s3tc_enable overridden by environment.
[x:ERROR:rewards_service_impl.cc(133)] Failed to read file: /home/user/.config/BraveSoftware/Brave-Browser/Default/ledger_state
Is this ok?

Just a note to all do not run with --no-sandbox option. Workaround has to be by enabling kernel namspaces as mentioned by @Mattches in here

2 Likes

Thanks everyone for the help!

2 Likes