"Block Element" is disabled in Private Window(s)

“Block Element” shows grayed out in Private Window(s) but seems unaffected in Normal Window(s)

Open any Private Window > Access any webpage > Right Click on White Space or Empty Space > Brave > “Block Element” is grayed out & disabled

“Block Element” used to work regardless of Normal or Private Window(s) but now it only works in the former

Version 1.46.144 Chromium: 108.0.5359.128 (Official Build) (64-bit)

This is how it is meant to be, they did it because of Privacy reasons https://github.com/brave/brave-browser/issues/25858

But Element pickers are not a good way to create cosmetic filters anyway, so nothing of value is lost, if you want to do it in a better way use DevTools, since you can see everything and properly make your cosmetics to be cleaner and better.

In general, the built-in element blocker will work perfectly fine for most users as it is simple and straightforward to use. That said, Emi is correct and the option was removed due to privacy concern when using the element blocker in Private sessions.