Aw Snap on first install / first load

I had never heard of the Brave browser until 20 mins ago, after seeing an ad on a site. So, I thought I would give it whirl and see what it’s like. After the new install and the first load, the initial tab shows the “Aw Snap” error.

I am quite familiar with this error from Chrome. It’s still an issue that I haven’t been able to solve after more than 6 months, even on fresh installs of Windows 10. The only way Chrome works for me is the “no sandbox” in the command line for the shortcut. But it causes a number of instability issues so I have to limit its use.

Anyways, I assume Brave and Chrome are built on the same platform? Since they share this identical flaw. Has anyone solved this issue for Brave? For some reason, Firefox and the Tor Browser don’t share this issue and have no problems running normally on any of my home systems.

Hey, sorry to see you having issues. Brave and Chrome both using the Chromium engine. Should be able to use the no sandbox in Brave also?

Also, does turning off Hardware Acceleration help?

Hey Ryan,

Thanks for getting back to me.

The “no sandbox” option does work in Brave but it isn’t the best option. I still don’t want to use it for anything secure, like banking, purchases, etc.

Turning off hardware acceleration doesn’t change anything. I turned it off, deleted the “no sandbox” extension and it gave the aw snap issue.

I am really at a loss on this aw snap thing. Seems like a lot of people have reported the same issue but there’s no documented reason why it happens or a valid fix. Up to 6 months ago, Google ran fine. Then I did a Windows Update after I put it off for years and it stopped functioning. I even set up a new computer/fresh install on new unused hardware the past weekend…installed Windows, downloaded Chrome and first load gave “Aw Snap”. The installation version of Windows was 1809 and I hadn’t run windows update yet.

Since Brave is built on the same platform and it produces the same issue as Chrome, it’s obviously an issue with the platform. Firefox runs flawlessly. My hardware is standard gaming level components….Asus prime motherboard, intel core i5 6600k, 32gigs of corsair memory, asus gtx 1070, sandisk extreme pro ssd boot drive. All drivers are up to date.

If you have any ideas, let me know.


Hello @Crourk,

Do you use a third party (non microsoft) security software ?
There was a known issue, which has already been discussed on that forum, with Symantec Endpoint Protection

It doesn’t quite match your fresh install description,
but does Brave work when you launch it with --disable-features=RendererCodeIntegrity ?

Hi MaximeJ,

First of all….this works for both Brave and Chrome


I was not aware of this issue. You wouldn’t believe how many posts I created on various websites or the amount of time over the past 6 months I spent researching this issue. Unfortunately, I have SEP running all 5 PC’s in my house that I purchased, so upgrading isn’t a desirable option.

Are there any drawbacks to using this workaround? ie, any security or instability issues? If there is nothing major to worry about, I will definitely start using Brave now as an alternative to Chrome. Google couldn’t even be bothered to respond to the multiple emails I sent.



Happy to help Chuck :slight_smile:

If upgrading isn’t an option, I would rather add an exception in Symantec for its feature causing this.
This way you let Brave works as it wants, with all the security features it has built-in. RendererCodeIntegrity prevents unsigned components to interfere with the browser’s renderer processes

You can follow these instructions:
with brave.exe under C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application

But I guess there wouldn’t be any instabilities if you go with the disable feature workaround, at least not caused by Brave itself.


Hey MaximeJ,

I tried setting an Application Exception in Symantec but for whatever reason it’s not working. I have SEP 12.1 RU6 build 7061 which is actually more recent than the article but mine looks different than below. It could be the way I installed it, as an unmanaged client. So, I would have to reinstall it and see it changes the ability to manipulate the program.

I’ll have to stick with the RenderCodeIntegrity switch for now on the command line.

I do appreciate leading me in the right direction. It’s obvious now that SEP is the culprit. Ultimately, I either have to figure out how to configure it properly or upgrade to a new version or another Firewall/Antivirus that’s compatible.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.